设置 Nginx 使用 HTTP/2 协议

Ubuntu/Debian Nginx设置HTTP/2

把软件源加入到/etc/apt/sources.list

更新 Nginx

HTTP/2 要求 Nginx 的版本最低为1.9.5

低版本没有http/2的支持,并报如下错误

打开 HTTP/2

由于HTTP/2是在TLS上实现的,所以需要一个SSL证书

在虚拟主机配置文件中加入 http2 关键字

你不可以同时启用SPDY和HTTP/2,否则将在Nginx启动时得到如下错误

重定向所有http请求到https

 

相关文章

发表评论

电子邮件地址不会被公开。 必填项已用*标注